Jump to content

Archived

This topic is now archived and is closed to further replies.

kieranexige

New car at last S190 Pics updated

Recommended Posts

20 hours ago, The Cakes said:

Nice find 🎯

Cheers Drage.

 

They took some finding, couldn't believe my luck when they were on the doorstep.

They get a thumbs up too 😂

IMG-20190102-WA0002.jpg

Share this post


Link to post
Share on other sites
On 20/12/2018 at 12:59, jonnyfox said:

I used helicopter tape across the top Kieran either side of the hole for the handbrake. And I also ran a thin strip either side along the base below the same area to protect against the seat frames.  You can't see it with the seats in. 

Thanks for the advice on the diffuser Jonny. 

Picked it up today. Properly chuffed. Prep is the Key like you say. 

_20190108_195822.JPG

Share this post


Link to post
Share on other sites

Great news Kieran. 

That's a great picture of the little fella in the seat. What a beaming smile :lol:

Share this post


Link to post
Share on other sites
On ‎09‎/‎01‎/‎2019 at 22:37, jonnyfox said:

Great news Kieran. 

That's a great picture of the little fella in the seat. What a beaming smile :lol:

Cheers Jonny, he didn't want to get out of it which is unusual as at the moment getting him to stop for more than 5 seconds is hard enough.

Share this post


Link to post
Share on other sites

Small progress update ... The Interior has been out, harness bar and bulkhead panel. The side carpets were coming away in places so the old tape was removed , glue cleaned an replaced with new.

I also replaced the speakers with new pioneer units whilst the harness bar was out. Of course they sit 8mm taller than the old units so are no pressed tightly against the harness's and the bar. My hand this morning looks like ive had a fight with a feral cat,

Harnesses have been washed and boy were they grim.... 

It's now almost all back in, seats are ready to go in on freshly powder coated rails once lotus send me the right toyota spec bolts and spacers, they sent K ones first even though I asked for the toyota part numbers.

 

Here's a quick test fit of the passenger seat running the msar harness bolt on the single shear side.  For some reason the seats look grey in the photo.

I've put the original 190 seats and runners in the loft in case I ever want to go back and sell the probax set.

All in all happy so far , the painted centre works really well and looks oem which is what I was looking for , without buying a brand new unscratched unit from lotus. The fabric probax also feel allot comfier than my old leather set in the exige, might just be me though , although having an air pump in the drivers is a huge plus  point on the comfort front.

 

 

 

On ‎20‎/‎12‎/‎2018 at 12:59, jonnyfox said:

 

 

DSC_6733.JPG

DSC_0000_BURST20190121223810055.JPG

Share this post


Link to post
Share on other sites
9 hours ago, Dr H said:

Looking great. Not that I expect anything less!

Haha, its far from your standards but cleaner than most. it would be nice to get these bolts , Junks is on it for me now. Although I do appear to have lost £700 to eliseparts. :eek:

Share this post


Link to post
Share on other sites

Looking lovely mate.  Are the footwells ok?  I found some corrosion on mine, under that ridiculous rubber sheet.  Luckily i found it in time before any holes opened up.

Share this post


Link to post
Share on other sites
1 hour ago, DeanB said:
Looking lovely mate.  Are the footwells ok?  I found some corrosion on mine, under that ridiculous rubber sheet.  Luckily i found it in time before any holes opened up.

Cheers Dean,

Postie delivered the missing seat bolts this morning so should have it buttoned up later.

No corrosion at all. I've had everything out and it's like new which I was chuffed about.

Sent from my G8141 using Tapatalk
 

Share this post


Link to post
Share on other sites

Looking great Kieran.   Roll on the spring when we can all crawl all over it - and you can do the same to the bogey green S160 no doubt!

Share this post


Link to post
Share on other sites
On 26/01/2019 at 09:03, DeanB said:

Looking lovely mate.  Are the footwells ok?  I found some corrosion on mine, under that ridiculous rubber sheet.  Luckily i found it in time before any holes opened up.

Rubber sheet in an S2? I thought that was only done during S1 production. 

Share this post


Link to post
Share on other sites
3 hours ago, Alex B said:

Rubber sheet in an S2? I thought that was only done during S1 production. 

I thought it was an S1 thing too.   Maybe Lotus had some rubber sheet left over 😆

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use