Midlands Lotus Owners Club (MLOC)

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.

Archived

This topic is now archived and is closed to further replies.

Alex B

New Toy...

33 posts in this topic

Well my new toy turned up today. Anyone notice my slight over sight?

uta7uja7.jpg

0

Share this post


Link to post
Share on other sites

You forgot to buy the link lead? Its a straight plug and play for the S1 ECU but not the S2 ECU.

 

Edit, pipped by Dr H :)

0

Share this post


Link to post
Share on other sites

S1 VVC loom is different to standard s1 loom, adapter will be ordered tonight. :)

0

Share this post


Link to post
Share on other sites

S1 VVC loom is different to standard s1 loom, adapter will be ordered tonight. smile.png

 

Indeed it would be. That still looks like an S2 ECU to me in the pic?

0

Share this post


Link to post
Share on other sites

Definitely an s1 ecu the serial number matcha up to an s1

0

Share this post


Link to post
Share on other sites

Definitely an s1 ecu the serial number matcha up to an s1

 

Well you live and learn. I thought all S1 ECU had one plug and S2 have 2 :)

0

Share this post


Link to post
Share on other sites

Mine only has 1 plug and it plugged straight into the Emerald.

 

However mine is a early S1.

0

Share this post


Link to post
Share on other sites

Maybe the S1 VVC has 2 plugs due to the solenoid control and the oil temp sensor for the solenoid control? I thought the Emerald was plug and play on all S1,s obviously not.

0

Share this post


Link to post
Share on other sites

Quite literally a schoolboy error young Alex...:-)

Said school boy error has been rectified! And hope should have my cable with me tomorrow. Just gotta wait for emerald to email me a map.

0

Share this post


Link to post
Share on other sites

Pretty sure i'm cursed!
just spoke to emerald and been informed my ecu doesn't have the correct hardware to run VVC

0

Share this post


Link to post
Share on other sites

You'll have to forgive me Alex I may own an S1 now but haven't really bothered to research it having had my head stuck under the S2 but what does it work on? I need laymans terms.......

0

Share this post


Link to post
Share on other sites