• advertisement_alt
  • advertisement_alt
  • advertisement_alt

Midlands Lotus Owners Club (MLOC)

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.

Archived

This topic is now archived and is closed to further replies.

MSH

Engine Malfunction Light

5 posts in this topic

I've had my MY 09 Exige S for just over 2 weeks and done around 300 miles. Last night I noticed the idle was irregular and acceleration a bit lumpy but still quite sharp. Today I went out for a drive with my daughter and we hadn't done a mile before the engine light came on. About turn and home for an early tea. I realise this is a very general area but any ideas what may cause this? Also, does the Exige have an OBD slot for a reader? One of these could save me hassle and money I guess.

 

Thanks in advance.

 

Mart

0

Share this post


Link to post
Share on other sites

passenger foot well


You need reader and a reset tool.

 

Don't worry too much as it will be the ecu putting the car into limp mode or a basic map.

 

For example on the 111s they tend to eat throttle sensors and coil packs can give similar issues to yours.

 

Get a reader on there and see what it says.

0

Share this post


Link to post
Share on other sites

Only have an iPhone but picked up an OBD reader with reset function etc. for £14 from amazon. The reviews look good so I find out tomorrow if it works or not.

0

Share this post


Link to post
Share on other sites