Jump to content
Caligarinet

Rover S2 wiper blade

Recommended Posts

Just fitted a Bosch AR24U wiper blade as recommended on various sites. 

It’s not clearing the screen in the centre of the blade, googling found someone else with similar issue, but not found a solution. 

Any recommendations?

Share this post


Link to post
Share on other sites

Seems I may need a different wiper arm, part number A117MO105F

anyone done this swap?

Well seems I already have the updated arm as it’s a u-shaped hook design and the AR24U fits but just doesn’t clear the screen. 

Edited by Caligarinet

Share this post


Link to post
Share on other sites

Have you tried giving the arm a gentle bend towards/away from the screen? I had the same thing some years ago and a slight tweak to the arm solved the problem, trouble is I can’t remember which way I went with it🙄

Share this post


Link to post
Share on other sites
2 hours ago, Jonathan E said:

Have you tried giving the arm a gentle bend towards/away from the screen? I had the same thing some years ago and a slight tweak to the arm solved the problem, trouble is I can’t remember which way I went with it🙄

I did the same, it worked, but can’t remember which way either! There is a post on Seloc explaining which way, which is where I educated myself!

Share this post


Link to post
Share on other sites

I did think about trying to bend the arm. 

Ended up exchanging it for a traditional sprung blade that is doing the job. 

Bosch SP24S

Thanks for advice. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use