Jump to content
Sign in to follow this  
Rick Fry

Elise S1 non starter

Recommended Posts

Hi sorry if this has been coverered before. I have an S1 elise that wont start. I have fuel and compression but no spark. Changed the coil pack, distributer cap, rotar arm. I dont appear to be getting 12v to the coil but dont have a wiring diagram so finding it quite a challenge.

Does anyone have a wiring diagram or any suggestions as to what this could be.

 

Thanks in advance

Share this post


Link to post
Share on other sites

Hi, have you checked the basics, battery condition, earths (g.box to chassis) and fuses? are other electrical functions ok?

I'm sure I downloaded a manual, if you cant find a wiring diagram I'll try and find where I saved it 🙂

Share this post


Link to post
Share on other sites

12V to the coil should come from the main relay, in the MFRU.  Then the ECU gives it a path to earth.  So the MFRU is the big suspect.  The coil comes from big plug pin 8, brown and pink wire.  Note that there are two pins with brown and pink wires, and they're connected to each other internally.  If there is no power there, then look for the relay input on pin 6, brown wire, which comes from the maxi fuse.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use