Jump to content
Sign in to follow this  
Rick Fry

Elise S1 non starter

Recommended Posts

Hi sorry if this has been coverered before. I have an S1 elise that wont start. I have fuel and compression but no spark. Changed the coil pack, distributer cap, rotar arm. I dont appear to be getting 12v to the coil but dont have a wiring diagram so finding it quite a challenge.

Does anyone have a wiring diagram or any suggestions as to what this could be.

 

Thanks in advance

Share this post


Link to post
Share on other sites

Hi, have you checked the basics, battery condition, earths (g.box to chassis) and fuses? are other electrical functions ok?

I'm sure I downloaded a manual, if you cant find a wiring diagram I'll try and find where I saved it 🙂

Share this post


Link to post
Share on other sites

12V to the coil should come from the main relay, in the MFRU.  Then the ECU gives it a path to earth.  So the MFRU is the big suspect.  The coil comes from big plug pin 8, brown and pink wire.  Note that there are two pins with brown and pink wires, and they're connected to each other internally.  If there is no power there, then look for the relay input on pin 6, brown wire, which comes from the maxi fuse.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use