Jump to content
Sign in to follow this  
jonnyfox

Exige S1 Restoration (images changed).

Recommended Posts

 

Quote

detailing Friday

Seems a bit superfluous given the pics we've been treated to.

 

PS: See you Sunday in my undetailed motor

Share this post


Link to post
Share on other sites

Not anymore fellas. Gearbox needs to come off, clutch to the floor, slave looks knackered and there is fluid everywhere. I'll be honest as it stands I'm pooped, I've got loads on and I'm juggling too many balls. I need to slow down the pace to be able to complete the car as I fully intended. Enjoy LitP, it'll be next year for me. 

 

Share this post


Link to post
Share on other sites

Bugger, that’s a huge shame! 

Share this post


Link to post
Share on other sites
1 hour ago, jonnyfox said:

Not anymore fellas. Gearbox needs to come off, clutch to the floor, slave looks knackered and there is fluid everywhere. I'll be honest as it stands I'm pooped, I've got loads on and I'm juggling too many balls. I need to slow down the pace to be able to complete the car as I fully intended. Enjoy LitP, it'll be next year for me. 

 

That's a pity Jonny, but it's pretty unusual to completely rebuild something in the way you have and not get any teething problems. Look forward to seeing it next year, I can;t make LitP again this year as I'm on hols. Maybe I can follow you next year in the Stratos - I'll just stick some Lotus badges on it and see if I can sneak in B)

Share this post


Link to post
Share on other sites

If it's just the slave cylinder then it's a straightforward job to fit a replacement so don't worry. Shouldn't need the 'box out for it.

Can't understand why Gav didn't spot it when it was there, as they usually start to weep when the seal's worn.

Share this post


Link to post
Share on other sites

It's brand new, no sign of any weeping while it was with Gav. Lol I know because he found other signs of weeping some other numpty was responsible for :blush:. The piston seems to have almost come right out. 

Share this post


Link to post
Share on other sites

Could of been worse. Wish I had of kept the original clutch arm and not gone with this piece of crap.

2018-07-25_09-30-00

 

Share this post


Link to post
Share on other sites

Good news that it's an easy fix! I presume?  But as you say, pretty crap it's failed straight away. Where was it form?

Edited by Dr H

Share this post


Link to post
Share on other sites

What a bugger and not easy to spot, At least a simple fix...... 

Share this post


Link to post
Share on other sites

New arm and slave, sorted. EP, I totally blame Martin :lol:

Just need to hunt a new original down tomorrow and get it to Gav before end of play. 

Edited by jonnyfox

Share this post


Link to post
Share on other sites

That is real bad luck. Hopefully its all ok once this is done.

Share this post


Link to post
Share on other sites

My first thought was bad hydrogen embrittlement, but looking closer it appears the weld is just crap - thin fillet and burned into the two parts.

Share this post


Link to post
Share on other sites
14 hours ago, jonnyfox said:

New arm and slave, sorted. EP, I totally blame Martin :lol:

Just need to hunt a new original down tomorrow and get it to Gav before end of play. 

 

Mines still going strong after loads of trackdays and sprints. Its also shortly going to Le Mans again for a trackday. Yours cant make it out the garage   :tongue2:

  • Sad 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue. Terms of Use