Midlands Lotus Owners Club (MLOC)

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.

Archived

This topic is now archived and is closed to further replies.

@ndy

Bedford Trackday - M3 Crash !

8 posts in this topic

Had a great day at Bedford on Monday, The Elise was on best behaviour and run all day with no problems. Not such a good day for the driver of the M3 thou, Both driver and passenger were ok but lost an hour while they cleaned up the mess - LINKY

 

Ended up with 3 Red flags on the day, The 2nd was when a Westfield decided to dump all it's fuel coming out the pit lane and ended up spinning on turn 1, I came out the pit 2 cars later spinning the rears as I got on the track to then find the Westfield stopped across the track on the exit of the corner !

 

The 3rd incident was when a Clio decided to let go of it's front wheel, My son was on track at that time and saw a random wheel slowly coming to a stop across the infield.

 

Great day thou with lots of track miles, Need new tyres now thou, overcooked the rears big time and the back end was very tail happy by the end of the day, Here's a video of Alex (my son) having fun smile.gif - LINKY

 

0

Share this post


Link to post
Share on other sites

A load of ppl on a forum im on (mk1 clio forum) were at this track day. Word on there was it was an instructor in with the guy who rolled the m3?! Not sure how true. But saw a close up pic of the aftermath! Will try find it and post it here!

 

post-3645-0-84810400-1400964829_thumb.jpg

post-3645-0-85965600-1400964864_thumb.jpg

0

Share this post


Link to post
Share on other sites

Andy, the car appears to be going well :)

0

Share this post


Link to post
Share on other sites

Andy,

 

I notice a dash light went at the hair pin after the long back straight. Might be worth investigating

 

It's the brake fluid level, I notice it now and then when on track even thou fluid level is good, I think my sensor in the cap is a little over sensitive ? I double checked the video and car this morning

 

Cheers for noticing thou, Better to be safe than sorry. thumbs_up.gif

Andy, the car appears to be going well smile.png

 

Yes, All going well Martin...... Fingers crossed !

0

Share this post


Link to post
Share on other sites

Andy, the car appears to be going well smile.png

 

Unlike the M3! :s That is a nasty roll, I suspect one the course desingers didnt expect to see either, it slides a hell of a long way.

 

Good job we don't know anyone who's just bought a car like that... ;)

 

(at least mine has 40 less horses!)

0

Share this post


Link to post
Share on other sites

Same corner, same slide put a 350z into the barrier which was deposited in the pit lane 2 years ago. I was lucky not to get a barrier on my car. The track had to be closed for the rest of the day as the warning light wiring came out with the barrier. Nobody was hurt but the 350z must have been finished.

 

I always say Bedford is great as there is nothing to hit, clearly not true.

 

My brake fluid light always comes on when on track, even if filled to the max. Same problem with the washer fluid bottle, which always gets emptied.

0

Share this post


Link to post
Share on other sites

You can have all the power in the world, fantastic brakes, stiffened suspension, but if the centre of gravity is too high, it will roll!!

0

Share this post


Link to post
Share on other sites