Midlands Lotus Owners Club (MLOC)

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.

Archived

This topic is now archived and is closed to further replies.

marky_p72

Think I Have The Dreaded Radiator Leak!

14 posts in this topic

Hi

As per title.

It's little strange tho, because it only happens once the engine reaches running temp (while driving), then it spits water/coolant up onto the passenger side of the windscreen, then stops. This happened last week on the breakfast run where I did around 300 miles & no further leakage, so header tank level is still good.

 

I have the car booked in for oil change service and I have mentioned to them about doing a pressure test.

I have my 1st track day booked on 9th June, so not sure whether to keep fingers crossed & hope it holds, or look into replacing before. (Will be gutted if it pops on the track day!!)

 

I also have an AA parts & labour warranty, so maybe if the pressure test fails I could make a claim!!

 

Any suggestions?

Cheers

Mark

0

Share this post


Link to post
Share on other sites

AA parts and labour only pay out if you break down. I had then same and called them, they said it was not a valid claim.

 

You would need to call them when you are out

0

Share this post


Link to post
Share on other sites

Ok, I thought it would be a bit too easy to just ring them up & get it done - no quibble!

Maybe if I can show them proof from the pressure test on Tues, they might accept!

0

Share this post


Link to post
Share on other sites

Break down a few miles away from unit 4 - say it was flicking water and some steam and seems to have stopped now whilst I was waiting ;o)

 

Oh - according to the internet there is an Elise place not far that we can take - nice easy fix & bonus for Mr AA man.

0

Share this post


Link to post
Share on other sites

Well, I have had the pressure test done and surprisingly it has passed. The chap who did it is as bemused as me!

The water has to be coming from the cooling system somewhere as its happening at the same point every time on the engine warm up, but no sign of any coolant loss yet!

0

Share this post


Link to post
Share on other sites

Make sure its not just the hose clip coming loose on the radiator inlet / outlet pipes.

0

Share this post


Link to post
Share on other sites

Take the wheel and wheel arch liner off and see if you can get to it. I have never tried on a Toyota model.

0

Share this post


Link to post
Share on other sites

Well, here's the update!

The water that was spitting up on to the windscreen stopped by itself, so took a gamble and carried on & did my track day at Bedford on Monday and had no problem at all. It's all very strange, but seems to have resolved itself! Happy days!

This was my 1st TD and had an amazing day! - There till the chequered flag! I've now booked Blyton for 10th Aug!!

Cheers for all the advice,

Mark

0

Share this post


Link to post
Share on other sites

Mark, there's Few of us doing Donny on 11th July evening session.

Glad you enjoyed your first TD, addictive aren't they!

0

Share this post


Link to post
Share on other sites

Mark, there's Few of us doing Donny on 11th July evening session.

Glad you enjoyed your first TD, addictive aren't they!

 

Yes, really enjoyed it.

Will have a think about Donnington. Might be a bit far for me just for an evening.

0

Share this post


Link to post
Share on other sites