Midlands Lotus Owners Club (MLOC)

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more!

This message will be removed once you have signed in.

Archived

This topic is now archived and is closed to further replies.

mneil

Evora Passenger Window Stopped Working

3 posts in this topic

went to open the passenger door this morning; not done so in an age and the window dropped slightly as usual but failed to raise and when i tried the window switch, failed to activate the window at all neither the near side switch or the drivers side switch. i know about the resetting of the top and bottom limits, have checked the fuse and found nothing blown, even changed it anyway. the drivers door window is responding as normal. also boot lights not working and fuse for those is fine. have also done the battery disconnect trick. any ideas please?

thanks neil

0

Share this post


Link to post
Share on other sites

I think I remember reading on the lotustalk website the door sensor/switch is the problem. I think it had got wet and contacts had corroded.

0

Share this post


Link to post
Share on other sites

Gav got to the bottom of it this morning; motor gone. just awaiting the new arrival and then back to unit 4 for installation.

0

Share this post


Link to post
Share on other sites